re = /(?=(?:(?:\\x1b\[[0-9;]+m)?.){80})(?:(?:\\x1b\[[0-9;]+m)?.){0,80}\K /
str = 'Morbi leo risus, \\x1b[34;1mporta ac consectetur\\x1b[39;22m ac, vestibulum at eros. Aenean lacinia bibendum nulla sed consectetur. Nullam id dolor id nibh ultricies vehicula ut id elit. Aenean lacinia bibendum nulla sed consectetur. Curabitur blandit tempus porttitor.'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result