import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+@\\w+\\.\\w{2,6}(\\.\\w{2})?";
final String string = "- fulano@cod3r.com.br\n"
+ " - xico@gmail.com\n"
+ " - joao@empresa.info.br\n"
+ " - maria_silva@registro.br\n"
+ " - rafa.sampaio@yahoo.com\n"
+ " - fulano+de+tal@escola.ninja.br";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}