$re = '/\S+@\w+\.\w{2,6}(\.\w{2})?/m';
$str = '- fulano@cod3r.com.br
- xico@gmail.com
- joao@empresa.info.br
- maria_silva@registro.br
- rafa.sampaio@yahoo.com
- fulano+de+tal@escola.ninja.br';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);