const regex = /\S+@\w+\.\w{2,6}(\.\w{2})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+@\\w+\\.\\w{2,6}(\\.\\w{2})?', 'gm')
const str = `- fulano@cod3r.com.br
- xico@gmail.com
- joao@empresa.info.br
- maria_silva@registro.br
- rafa.sampaio@yahoo.com
- fulano+de+tal@escola.ninja.br`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}