import re
regex = re.compile(r"\b[(A-H|J-N|P|R-Z|0-9)]{17}\b", flags=re.MULTILINE)
test_str = ("The VIN number on a vehicle is a 17 alpha-numeric characters and must NOT contain the letters I, O or Q (to avoid confusion with the similar looking digits). \n"
"So, for example, SALVA2AE4EH877322 is valid, but SALVO2AE4EH877322 is not.\n"
"By using the \\b word boundary token, we can match in quotes \"SALVA2AE4EH877482\", brackets (SALVA2AE4EH877998) or other boundaries that people may use <SALVA2AE4EH877002>\n\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")