import Foundation
let pattern = #"\b[(A-H|J-N|P|R-Z|0-9)]{17}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The VIN number on a vehicle is a 17 alpha-numeric characters and must NOT contain the letters I, O or Q (to avoid confusion with the similar looking digits). 
So, for example, SALVA2AE4EH877322 is valid, but SALVO2AE4EH877322 is not.
By using the \b word boundary token, we can match in quotes "SALVA2AE4EH877482", brackets (SALVA2AE4EH877998) or other boundaries that people may use <SALVA2AE4EH877002>
 
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)