use strict;
my $str = '<+play ing+> <+game s .+>';
my $regex = qr/<\+|\+>|(?<!>) | (?!<)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";