re = /<\+|\+>|(?<!>) | (?!<)/m
str = '<+play ing+> <+game s .+>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result