import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=showPollResponses\\()(.*)(?=width:45%)";
final String string = "</thead>\n"
+ "<tr>\n"
+ "<td class=\"oddpoll\" style=\"width:20%\"><b><a href=\"#\" onclick=\"showPollResponses(123456, 99, '1A2B3C4D5E6F7G8H9I0J1K2L3M4N5O6P', 123456, 123456, 99);return false;\">The stuf (i</a></b>\n"
+ "<br>\n"
+ "</td><td class=\"oddpoll\" style=\"width:35%\">The content was pretty nice and would participate again </td><td class=\"oddpoll\" style=\"width:45%\"><b>123 Total</b>\n"
+ "<br>\n"
+ "</td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td class=\"oddpoll\"> </td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}