re = /(?<=showPollResponses\()(.*)(?=width:45%)/
str = '</thead>
<tr>
<td class="oddpoll" style="width:20%"><b><a href="#" onclick="showPollResponses(123456, 99, \'1A2B3C4D5E6F7G8H9I0J1K2L3M4N5O6P\', 123456, 123456, 99);return false;">The stuf (i</a></b>
<br>
</td><td class="oddpoll" style="width:35%">The content was pretty nice and would participate again </td><td class="oddpoll" style="width:45%"><b>123 Total</b>
<br>
</td>
</tr>
<tr>
<td class="oddpoll"> </td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end