import re
regex = re.compile(r"(?<=showPollResponses\()(.*)(?=width:45%)")
test_str = ("</thead>\n"
"<tr>\n"
"<td class=\"oddpoll\" style=\"width:20%\"><b><a href=\"#\" onclick=\"showPollResponses(123456, 99, '1A2B3C4D5E6F7G8H9I0J1K2L3M4N5O6P', 123456, 123456, 99);return false;\">The stuf (i</a></b>\n"
"<br>\n"
"</td><td class=\"oddpoll\" style=\"width:35%\">The content was pretty nice and would participate again </td><td class=\"oddpoll\" style=\"width:45%\"><b>123 Total</b>\n"
"<br>\n"
"</td>\n"
"</tr>\n"
"<tr>\n"
"<td class=\"oddpoll\"> </td>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")