use strict;
my $str = 'run.\\r\\nTimeframe (PT) Success Failed % Failed\\r\\n\\r\\n05:15-06:14\\r\\n\\r\\n58570\\r\\n\\r\\n681\\r\\n\\r\\n1.15\\r\\n\\r\\nIf you believe you\'ve received this email in error, please see your Splunk"}';
my $regex = qr/(?i)nTimeframe\s+\(\w+\)\s+\w+\s+\w+\s+\%\s+\w+\\\w+\\\w+\\\w+\\\w\d+\:\d+\-\d+\:\d+\\\w+\\\w+\\\w+\\\w(?P<Successful>\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}