// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)nTimeframe\s+\(\w+\)\s+\w+\s+\w+\s+\%\s+\w+\\\w+\\\w+\\\w+\\\w\d+\:\d+\-\d+\:\d+\\\w+\\\w+\\\w+\\\w(?P<Successful>\d+)").unwrap();
let string = "run.\\r\\nTimeframe (PT) Success Failed % Failed\\r\\n\\r\\n05:15-06:14\\r\\n\\r\\n58570\\r\\n\\r\\n681\\r\\n\\r\\n1.15\\r\\n\\r\\nIf you believe you've received this email in error, please see your Splunk\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}