re = /(?i)nTimeframe\s+\(\w+\)\s+\w+\s+\w+\s+\%\s+\w+\\\w+\\\w+\\\w+\\\w\d+\:\d+\-\d+\:\d+\\\w+\\\w+\\\w+\\\w(?P<Successful>\d+)/m
str = 'run.\\r\\nTimeframe (PT) Success Failed % Failed\\r\\n\\r\\n05:15-06:14\\r\\n\\r\\n58570\\r\\n\\r\\n681\\r\\n\\r\\n1.15\\r\\n\\r\\nIf you believe you\'ve received this email in error, please see your Splunk"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end