package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((([^\/]*)\/*){1}))`)
var str = `demo.codesamplez.com/html5/////////////////////////audio/////wsfsdf/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}