$re = '/^(((([^\/]*)\/*){1}))/m';
$str = 'demo.codesamplez.com/html5/////////////////////////audio/////wsfsdf/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);