re = /^(((([^\/]*)\/*){1}))/m
str = 'demo.codesamplez.com/html5/////////////////////////audio/////wsfsdf/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end