#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)SELECT((?:.(?!SELECT))*)FROM INSERTED"
Local $sString = "SELECT 1 FROM INSERTED i" & @CRLF & _
"" & @CRLF & _
"SELECT 'Hello, world!' FROM INSERTED i" & @CRLF & _
"" & @CRLF & _
"SET @foo = (SELECT @@userid)" & @CRLF & _
"" & @CRLF & _
"SELECT * FROM INSERTED i" & @CRLF & _
"" & @CRLF & _
"SELECT" & @CRLF & _
" One," & @CRLF & _
" Two," & @CRLF & _
" Three, Four," & @CRLF & _
" Five," & @CRLF & _
" Six, Seven, Eight," & @CRLF & _
" Nine, Ten" & @CRLF & _
"FROM INSERTED i" & @CRLF & _
"" & @CRLF & _
"SET @bar = (SELECT TOP(1) PatronID FROM INSERTED i)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")