using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT((?:.(?!SELECT))*)FROM INSERTED";
string input = @"SELECT 1 FROM INSERTED i
SELECT 'Hello, world!' FROM INSERTED i
SET @foo = (SELECT @@userid)
SELECT * FROM INSERTED i
SELECT
One,
Two,
Three, Four,
Five,
Six, Seven, Eight,
Nine, Ten
FROM INSERTED i
SET @bar = (SELECT TOP(1) PatronID FROM INSERTED i)";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}