re = /SELECT((?:.(?!SELECT))*)FROM INSERTED/im
str = 'SELECT 1 FROM INSERTED i
SELECT \'Hello, world!\' FROM INSERTED i
SET @foo = (SELECT @@userid)
SELECT * FROM INSERTED i
SELECT
One,
Two,
Three, Four,
Five,
Six, Seven, Eight,
Nine, Ten
FROM INSERTED i
SET @bar = (SELECT TOP(1) PatronID FROM INSERTED i)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end