package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[\s]*[^#\n]*Options.*)(\s+)(FollowSymLinks)`)
var str = `# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
Options Indexes FollowSymLinks
Options Indexes FollowSymLinks
Options FollowSymLinks
Options -FollowSymLinks
Indexes FollowSymLinks
# Options Indexes FollowSymLinks
#Options Indexes FollowSymLinks
# Options Indexes FollowSymLinks
#Options Indexes FollowSymLinks`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}