// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[\s]*[^#\n]*Options.*)(\s+)(FollowSymLinks)").unwrap();
let string = "# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
Options Indexes FollowSymLinks
Options Indexes FollowSymLinks
Options FollowSymLinks
Options -FollowSymLinks
Indexes FollowSymLinks
# Options Indexes FollowSymLinks
#Options Indexes FollowSymLinks
# Options Indexes FollowSymLinks
#Options Indexes FollowSymLinks";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}