#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Start Group\r?\nName = "ITEM TYPE 2"\r?\n(?>(?!End Group$).*\r?\n)*End Group$"
Local $sString = "Start Group" & @CRLF & _
"Name = "ITEM TYPE 1"" & @CRLF & _
"ID = [ID_1]" & @CRLF & _
"stuff" & @CRLF & _
"stuff" & @CRLF & _
"stuff" & @CRLF & _
"End Group" & @CRLF & _
"" & @CRLF & _
"Start Group" & @CRLF & _
"Name = "ITEM TYPE 2"" & @CRLF & _
"ID = [ID_2]" & @CRLF & _
"stuff" & @CRLF & _
"stuff" & @CRLF & _
"stuff" & @CRLF & _
"stuff" & @CRLF & _
"End Group" & @CRLF & _
"" & @CRLF & _
"Start Group" & @CRLF & _
"Name = "ITEM TYPE 1"" & @CRLF & _
"ID = [ID_3]" & @CRLF & _
"stuff" & @CRLF & _
"End Group" & @CRLF & _
"" & @CRLF & _
"Start Group" & @CRLF & _
"Name = "ITEM TYPE 2"" & @CRLF & _
"ID = [ID_4]" & @CRLF & _
"stuff" & @CRLF & _
"stuff" & @CRLF & _
"End Group"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")