use strict;
my $str = 'Start Group
Name = "ITEM TYPE 1"
ID = [ID_1]
stuff
stuff
stuff
End Group
Start Group
Name = "ITEM TYPE 2"
ID = [ID_2]
stuff
stuff
stuff
stuff
End Group
Start Group
Name = "ITEM TYPE 1"
ID = [ID_3]
stuff
End Group
Start Group
Name = "ITEM TYPE 2"
ID = [ID_4]
stuff
stuff
End Group';
my $regex = qr/^Start Group\r?\nName = "ITEM TYPE 2"\r?\n(?>(?!End Group$).*\r?\n)*End Group$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}