$re = '/^Start Group\r?\nName = "ITEM TYPE 2"\r?\n(?>(?!End Group$).*\r?\n)*End Group$/m';
$str = 'Start Group
Name = "ITEM TYPE 1"
ID = [ID_1]
stuff
stuff
stuff
End Group
Start Group
Name = "ITEM TYPE 2"
ID = [ID_2]
stuff
stuff
stuff
stuff
End Group
Start Group
Name = "ITEM TYPE 1"
ID = [ID_3]
stuff
End Group
Start Group
Name = "ITEM TYPE 2"
ID = [ID_4]
stuff
stuff
End Group';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);