using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]{2})?[\s-]*[0-9]{4,5}[\s-]*([a-zA-Z]{2})?";
string input = @"13245DE
1324
13245 DE
13245-DE
13245-de
13245 de
DE 13245
DE-13245
de 13245
de-13245
132
123456
12345 d
d 12345
asdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}