re = /([a-zA-Z]{2})?[\s-]*[0-9]{4,5}[\s-]*([a-zA-Z]{2})?/m
str = '13245DE
1324
13245 DE
13245-DE
13245-de
13245 de
DE 13245
DE-13245
de 13245
de-13245
132
123456
12345 d
d 12345
asdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end