const regex = /([a-zA-Z]{2})?[\s-]*[0-9]{4,5}[\s-]*([a-zA-Z]{2})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]{2})?[\\s-]*[0-9]{4,5}[\\s-]*([a-zA-Z]{2})?', 'gm')
const str = `13245DE
1324
13245 DE
13245-DE
13245-de
13245 de
DE 13245
DE-13245
de 13245
de-13245
132
123456
12345 d
d 12345
asdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}