import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-z]:)?[\\/\\\\]{0,2}(?:[.\\/\\\\ ](?![.\\/\\\\\\n])|[^<>:\"|?*.\\/\\\\ \\n])+$";
final String string = "C://test\n"
+ "C://te?st.html\n"
+ "C:/test\n"
+ "C://test.html\n"
+ "C://test/hello.html\n"
+ "C:/test/hello.html\n"
+ "//test\n"
+ "/test\n"
+ "//test.html\n"
+ "//10.1.1.107\n"
+ "//10.1.1.107/test.html\n"
+ "//10.1.1.107/te st/hello.html\n"
+ "//10.1.1.107/test/hello\n"
+ "//test/hello.txt\n"
+ "/test/html\n"
+ "/tes?t/html\n"
+ "/test.html\n"
+ "test.html\n"
+ "//\n"
+ "/\n"
+ "\\\\\\\\\n"
+ "\\\\\n"
+ "/t!esrtr\n"
+ "C:/hel**o\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}