import re
regex = re.compile(r"^(?:[a-z]:)?[\/\\]{0,2}(?:[.\/\\ ](?![.\/\\\n])|[^<>:\"|?*.\/\\ \n])+$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("C://test\n"
"C://te?st.html\n"
"C:/test\n"
"C://test.html\n"
"C://test/hello.html\n"
"C:/test/hello.html\n"
"//test\n"
"/test\n"
"//test.html\n"
"//10.1.1.107\n"
"//10.1.1.107/test.html\n"
"//10.1.1.107/te st/hello.html\n"
"//10.1.1.107/test/hello\n"
"//test/hello.txt\n"
"/test/html\n"
"/tes?t/html\n"
"/test.html\n"
"test.html\n"
"//\n"
"/\n"
"\\\\\\\\\n"
"\\\\\n"
"/t!esrtr\n"
"C:/hel**o\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")