package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^proj[a-zA-Z0-9]*_[a-zA-Z]+(?:_[0-9]+)?\.[a-z]+\.[a-z]+$`)
var str = `proj_asdasd_000.gz.xml
proj_asdasd.gz.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}