const regex = /^proj[a-zA-Z0-9]*_[a-zA-Z]+(?:_[0-9]+)?\.[a-z]+\.[a-z]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^proj[a-zA-Z0-9]*_[a-zA-Z]+(?:_[0-9]+)?\\.[a-z]+\\.[a-z]+$', 'gm')
const str = `proj_asdasd_000.gz.xml
proj_asdasd.gz.xml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}