package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z.0-9]+)`)
var str = `/indoor-unit-for-split-acs-carrier-EL.AI.CA.468725/
/solar-inverters-su-kam-SO.SO.SO1.347598/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}