$re = '/([A-Z.0-9]+)/';
$str = '/indoor-unit-for-split-acs-carrier-EL.AI.CA.468725/
/solar-inverters-su-kam-SO.SO.SO1.347598/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);