re = /([A-Z.0-9]+)/
str = '/indoor-unit-for-split-acs-carrier-EL.AI.CA.468725/
/solar-inverters-su-kam-SO.SO.SO1.347598/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end