use strict;
my $str = 'Devices:\\n\\thci1\\t00:50:B6:80:4D:5D\\n\\thci0\\t00:15:83:15:A2:CB\\n';
my $regex = qr/([0-9A-Fa-f]{2}[:]){5}([0-9A-Fa-f]{2})/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}