re = /([0-9A-Fa-f]{2}[:]){5}([0-9A-Fa-f]{2})/m
str = 'Devices:\\n\\thci1\\t00:50:B6:80:4D:5D\\n\\thci0\\t00:15:83:15:A2:CB\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end