import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?!off\\b)[a-z]+[^\\w,\\n]+)*?\\b(?:way|road|str(?:eet)?)\\b(?:[^\\w,\\n]+[a-z]+)*";
final String string = "1. Yeet Road, Off Mandy Plant Way, Mando GRA.\n"
+ "2. 3A, Sleek Drive, Off Tremble Rake Street.\n"
+ "3. 57 Radish Slist Road Ikoyi ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}