const regex = /\b(?:(?!off\b)[a-z]+[^\w,\n]+)*?\b(?:way|road|str(?:eet)?)\b(?:[^\w,\n]+[a-z]+)*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?!off\\b)[a-z]+[^\\w,\\n]+)*?\\b(?:way|road|str(?:eet)?)\\b(?:[^\\w,\\n]+[a-z]+)*', 'gi')
const str = `1. Yeet Road, Off Mandy Plant Way, Mando GRA.
2. 3A, Sleek Drive, Off Tremble Rake Street.
3. 57 Radish Slist Road Ikoyi `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}