re = /\b(?:(?!off\b)[a-z]+[^\w,\n]+)*?\b(?:way|road|str(?:eet)?)\b(?:[^\w,\n]+[a-z]+)*/i
str = '1. Yeet Road, Off Mandy Plant Way, Mando GRA.
2. 3A, Sleek Drive, Off Tremble Rake Street.
3. 57 Radish Slist Road Ikoyi '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end