import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d[\\d\\- ]*[A-Z]?\\b";
final String string = "Via Treviso Mare 2 => need to detect 2\n"
+ "8C via Sergio Leone => need to detect 8C\n"
+ "Strada Provinciale 22 C => need to detect 22 C\n"
+ "19-20 Frazione Santa Maria => need to detect 19-20\n"
+ "9 - 11 via Giare => need to detect 9 - 11\n"
+ "Via Cesare Taiti 18-B => need to detect 18-B";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}