package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){start}([\S\s]*?){end}`)
var str = `Please get the data between {start}
and the
{end} tag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}