re = /{start}([\S\s]*?){end}/m
str = 'Please get the data between {start}
and the
{end} tag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end