$re = '/[A-Za-z ]+(\s\d+)+\s?/m';
$str = 'Carroll 103 215 Albany City 24 41 Allegany 115 231 Charlotte 116 248 111 Other 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);