re = /[A-Za-z ]+(\s\d+)+\s?/m
str = 'Carroll 103 215 Albany City 24 41 Allegany 115 231 Charlotte 116 248 111 Other 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end