// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z ]+(\s\d+)+\s?").unwrap();
let string = "Carroll 103 215 Albany City 24 41 Allegany 115 231 Charlotte 116 248 111 Other 123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}