import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "content=['\"](.*)['\"]";
final String string = "<meta name='description' content='В октябре на хоздворе в основном занимаются утеплением помещений, закладкой силосной ямы из остатков овощей и фруктов, заготовкой сена, ремонтом загонов для зимовки скота.'>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}