import Foundation
let pattern = #"content=['"](.*)['"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<meta name='description' content='В октябре на хоздворе в основном занимаются утеплением помещений, закладкой силосной ямы из остатков овощей и фруктов, заготовкой сена, ремонтом загонов для зимовки скота.'>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)