import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+\"(?<id>[0-9]+)\"\\s+\"(?<path>.+)\"$";
final String string = "\"LibraryFolders\"\n"
+ "{\n"
+ " \"TimeNextStatsReport\" \"1613549278\"\n"
+ " \"ContentStatsID\" \"8305207799611222323\"\n"
+ " \"1\" \"E:\\\\Games\\\\SteamLibrary\"\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}