const regex = /^\s+"(?<id>[0-9]+)"\s+"(?<path>.+)"$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+"(?<id>[0-9]+)"\\s+"(?<path>.+)"$', 'gm')
const str = `"LibraryFolders"
{
"TimeNextStatsReport" "1613549278"
"ContentStatsID" "8305207799611222323"
"1" "E:\\\\Games\\\\SteamLibrary"
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}